Miranda ProZ und Vista 32Bit

Abermals: Neues Gadget (neuer Laptop) und neue Herausforderungen. Das von mir favorisierte Miranda komplett Paket „ProZ“ hat auf Grund eines veralteten Datenbanktreibers ein Problem mit Windows Vista 32 Bit.

Problembeschreibung

Beim Starten von Miranda erscheint jeweils eine Fehlermeldung, die auf eine inkompatibilität eines Plugins hinweist.

Lösung

Die Lösung des Problems wird in diesem Thread angeschnitten aber nicht detailliert ausgeführt.

Schuld ist der veraltete Datenbanktreiber dbx_3xsa.dll. Leider ist dieser zwar in der Pluginliste aufgeführt, lässt sich aber nicht so einfach deaktivieren. Wie bereits im oben genannten Thread erläutert, gilt es das genannte Plugin bzw. den Treiber durch eine Alternative zu ersetzen.

Meine Wahl fiel auf den „Dbx_mmap_secured“ genannten Treiber. Nähere Erläuterungen und einen Downloadlink gibt es im Miranda-IM Wiki. Selbiger wird heruntergeladen und nebst verändertem DBTool im Mirandaverzeichnis entpackt. Weiterhin habe ich die dbx_3xsa.dll entfernt.

Nun ggf. noch das neue DBTool ausführen und in dem Zusammenhang die Datenbank reparieren lassen. Danach sollte sich Miranda ohne Fehlermeldung starten lassen, auch ein Datenverlust ist nicht zu erwarten.

Hinweis: Vor derartigen Bastelein empfiehlt sich ein Vollbackup, welches bei Miranda durch einfaches kopieren des gesamten Ordners recht trivial angelegt werden kann.

Hauppauge Nova-HD-S2 und Vista 64Bit

Mal wieder: Neues Spielzeug, neue Probleme. Meine (etwas) ältere Nova-HD-S2 mag nicht so recht mit meinem neuen Windows Vista 64Bit Ultimate zusammen spielen. Als gewünschte Software kam bzw. kommt DVBViewer zum Einsatz, was aber unerheblich für das Problem ist.

Rahmenbedingungen:

  • Vista Ultimate 64 Bit
  • Hauppauge WinTV Nova-HD-S2 mit den aktuellen Treibern der Hauppauge Website
  • Mainboard: Asus P5Q-E mit Intel P45 Chipset, neuste Treiber
  • Grafikkarte: ATI Radeon HD 4850, aktueller Catalyst 8.9
  • Media Player: PowerDVD 8
  • DVB Viewer Version: Sowohl aktuelle Stable, als auch aktuelle Beta

Problembeschreibung

Für jeden Kanal (fertige Kanalliste) wird angezeigt: „Für diesen Sender ist kein DVB-Gerät verfügbar“.
Das gleiche passiert auch wenn ich den Sendersuchlauf starte. Selbiger steht dabei natürlich auf Satellite.
In den Einstellungen wird die Karte jedoch korrekt gefunden, wenn ich auf Gerät suchen klicke. Natürlich habe ich nach dem Update auf die aktuelle Beta den Hardwaresuchlauf erneut laufen lassen.

Lösung

Zum Zeitpunkt meiner Tests hatte Hauppauge unsignierte Treiber auf seiner Homepage. Falls sich dies auch bis heute nicht geändert hat, dürfte immernoch folgende Lösung gelten:

  1. Vista 32 Bit verwenden, dem die unsignierten Treiber egal sind -> nicht so schön, da mein neues System über 4GB Ram verfügt
  2. Windows in einen speziellen Modus versetzen und die Treiber selbst signieren -> hässlich
  3. Ein spezielles Tool nehmen, welches die Treibersignaturüberprüfung dauerhaft abschaltet -> hässlich, weil öffnet auch die Tür für Rootkits etc
  4. Die Treiber aus diesem Thread verwenden. Sie sind älter, signiert und funktionieren bei mir super. Für den Fall das der Thread mal verschwindet, sind die Treiber hier direkt verlinkt.

Um zu überprüfen, ob der Treiber bzw. sein Signaturstatus das Problem ist, kann Windows auch einmalig ohne Treibervalidierung gestartet werden. Dazu vor dem Vista Boot das Bootmenü öffnen (Ich glaub via F6 war’s) und den entsprechenden Punkt wählen. Bei mir hat dann – natürlich nur bis zum nächsten Reboot – alles funktioniert.

Gallery 2 Hauptansicht anpassen

Im Rahmen des Gallery Updates wurde mein angepasstes Template zurücküberschrieben. Wichtigste Eigenheiten:

  • Kein „Album: “ vor den Titeln der Alben
  • Keine Anzeige des Erstellungsdatums (füge ich händisch über die Eigenschaften des jeweiligen Albums hinzu)
  1. Öffne die Datei
    /var/www/gallery2/themes/matrix/templates/album.tpl
  2. Finde die Zeichenkette
     {* Add prefix for albums unless imageframe will differentiate *}
     {g->text text="Album: %s" arg1=$child.title|markup}
  3. Entferne die Zeichen „Album:“
  4. Finde die Zeichenkette
     {g->block type="core.ItemInfo"
                       item=$theme.item
                       showDate=true
  5. Setze showDate=true auf showDate=false

Gallery2 Logogröße verändern

Altes Spielzeug, neues Update, neues Problem.

Im Rahmen meiner Gallery 2 Installation vor über einem Jahr habe ich selbige etwas versucht an ein von mir gewünschtes Design anzupassen. Jene Änderungen enthielten ein größeres Logo und wurden beim letzten Update überschrieben. Folgend die notwendigen Schritte, um die Größe des Logos auf einen neuen Wert zu ändern:

  1. Öffne die Datei
    /var/www/gallery2/themes/matrix/templates/theme.tpl
  2. Finde den Wert „107“
  3. Ersetze die gefundene Passage durch:
    <img src="{g->url href="images/dingsbums.gif"}" width="468" height="60"
  4. Finde den Abschnitt
    <div id="gsHeader">alt=""/>
  5. Ersetze diesen durch
    <div id="gsHeader">
            <a href="{g->url}"><img src="{g->url href="images/dingsbums.gif"}"
             width="468" height="60" alt=""/></a>
    </div>
  6. Führe die Wartungsaufgabe „Vorlagenpuffer leeren“ im Administrationsbereich durch!